When using the Egress Secure Email Add-in for Outlook 2016, you may receive the error message below:

To resolve this issue, please ensure you're on the latest version of the Egress Client, which is available to download from our Client Download page.

If you require any further support following this, please contact Support.



Have more questions? Submit a request