When trying to send a Egress secure email inside of Outlook you may receive an error message similar to the error below. This error is not directly related to the Egress Client but related to an Office resource which the Outlook Add-in uses.

 

Fix 1 – Repair/Reinstall office

You may need to repair your Office installation. In some cases reinstalling Office may be needed as this will override any incorrect registry keys and may resolve the issue once the machine has been restarted.

Fix 2 – Registry Keys

  1. Open up Regedit (Keyboard shortcut: Win + R then type Regedit and click OK)
  2. Locate to HKEY_CLASSES_ROOT\TypeLib\{00062FFF-0000-0000-C000-000000000046}
  3. Please make a backup of this registry location before making any changes!
  4. Delete the version keys (e.g. 9.5) for any version of Outlook that is not installed on the customer’s machine based on the version table provided below.

 

Outlook Versions

Outlook 2007 - 9.3

Outlook 2010 - 9.4

Outlook 2013 - 9.5

Outlook 2016 - 9.6


After this change has been made please restart Outlook and the Egress Client (you can end the Egress Client in task manager). 

In some cases, a registry key change may not resolve the issue, Reinstalling office will override any incorrect keys and may resolve the issue once the machine has been restarted.

 

Fix 3Ensure that Microsoft Primary Interop Assemblies Redistributable package is installed

This is installed as default by Microsoft but we have known this to be fixed by installing again.

This can be downloaded from here (and is Office version dependent).

 



Have more questions? Submit a request