System Requirements

The Egress Client for Mac requires Mac OS X v10.6 (Snow Leopard) or later.

 

Installation

The easiest way to install Egress Client on a Mac is by going into the ‘App Store’ and then searching for Egress Client in the search box.

Once you have searched for the Egress Client app, you should be able to see this in the search results. If you then click onto the app you can then download for free. 

 

 



Have more questions? Submit a request